Updating rubygems on leopard

Rated 4.55/5 based on 910 customer reviews

[on OFTC Internet Relay Chat Link Address] Mac's with version 10.5 Leopard or higher already have Ruby and Ruby Gems installed, Ruby and Ruby Gems update instructions are found here at the Homebrew for OS X page, as well as instructions for adding Homebrew to your OS X machine if you do not already have it installed.If you are using an earlier version of Mac OS like 10.3 or 10.4, try following any directions at Ruby Gems to see if your version is still supported officially or not, plus there many community workarounds and tips for those wishing to still make use of OS X or Pure Darwin sometimes registers here too on older machines or newer machines both.At that point, I installed the latest versions of everything needed onto my Macbook Pro.In the meantime, I've upgraded to Leopard, installed a larger hard drive (using Time Machine to restore), and most importantly, not done anything to update Ruby, Rails, any of the gems, or even checked to see if they work.Ruby Gems then can be installed by just clicking on the button labeled 'Install', thats it.Be sure to Follow any extra instructions from the Software Center should there be any during or after installation.Using the editor of your choice, create and edit a file in your home directory named at the beginning of the line returned by the system.We’re going to create a folder to contain the files we’re about to download and compile.

Install Ruby like shown below: $ sudo yum install ruby If you are using Red Hat Enterprise Linux 6, enable the Optional channel for your host by logging into Red Hat Network (RHN).However, IIRC, there was a problem with the Leopard install of rubygems, and you need to use the following first : " by itself will attempt to update every gem installed on your system. What happened when you ran it is that at least one of the gems installed on your system relies on an underlying "binary" dependency, meaning code written (most likely) in the C programming language and inteneded to be built into a native binary that the Ruby gem relies on to do the heavy lifting part of its work.This native code failed to compile, and the gem update aborted because of that.If you saw something different, you haven’t set your path correctly. Open up the 'Software Center' app from your launcher and type in `Ruby Gems` without quotes into the application search box at the top right, and press [enter].

Leave a Reply